DNS failure
Incident Report for Akamai Identity Cloud
Postmortem

July 27, 2021

A full RCA has been published that is available to you upon request of your Akamai sales team. This may be shared with your organization under NDA.

Sincerely,

Andrew Ward (CISSP)

July 23, 2021

This service incident that impacted Akamai Identity Cloud (AIC) was a result of the global outage affecting DNS services on the Akamai Enhanced SSL (ESSL) network. The AIC solution relies upon the ESSL network and DNS for service delivery. At this time it appears a software change was implemented that incurred a defect in DNS. The software change was rolled back within an hour and the situation was fully mitigated.

At this time the Akamai incident management team continues to investigate the matter. A Root Cause Analysis (RCA) can be expected in the future, but given the complexity and scale of the this event AIC customers should expect a week or longer may be needed for a RCA to be published by the incident management team.

Sincerely,

Andrew Ward (CISSP)
Sr. Director Product Management
Akamai Technologies, Inc.

Posted Jul 23, 2021 - 12:56 UTC

Resolved
Service recovered, we're continuing to monitor closely.
Posted Jul 22, 2021 - 17:29 UTC
Update
We've identified emergency measures that will allow us to recover Capture API service, and are in progress applying it everywhere. In some certain regions, the Capture service is already partially or fully recovered.
We're currently investigating additional methods to restore all services.
Posted Jul 22, 2021 - 16:36 UTC
Investigating
The AIC Platform across all regions are currently affected by a DNS failure, we're currently investigating the root cause and actively working to restore the service.
Posted Jul 22, 2021 - 16:29 UTC
This incident affected: Australia, Canada, China, Europe, Japan, Russia, Singapore, and United States.